Verification hash error


#1

iPhone X
iOS 13.3.1

Instrument 1
Firmware 1.0.23

I just received a used Instrument 1 I purchased online. I connected it to my iPhone and launched the Artiphon iOS app which recommended a firmware update.

I get the error: Verification hash error.

I’ve searched these forums and the recommendations I saw seem to be:
Turn the I1 off and on again
Restart the app
Try the firmware update again

I’ve tried that many times and I keep getting the same error.

I’m attempting to update to firmware 1.1.20

What are the next steps after that?

I have a MacBook Pro. I installed the Artiphon INSTRUMENT 1 Editor. When I run that app and connect my I1 to the MBP, it seems like nothing happens. Is this because the firmware on the I1 is too old?

Thanks!


#2

Might be a cable issue. To update firmware via the iOS app you need to use the original Artiphon cable; firmware updates won’t work through an adaptor, though you can otherwise connect and play normally.

I’m not sure what’s going on with the MacBook, though – that should allow you to update via the editor (under the Help menu). When you say nothing happens, is it:

  1. that the I1 doesn’t connect (i.e. the lights on the bridge continue to go back and forth)?

  2. that you get the connection lights (in a circle round the knob) but the editor doesn’t show the I1 as connected (icon of an I1 should appear under the Artiphon icon at top left, with the onboard presets in a list below it)?

  3. that the editor connects, but doesn’t produce any sound? (That’s actually normal; only the iOS app has sounds built in. You should still be able to update firmware & edit/install presets.)

  4. something else again?


#3

Updating firmware via iOS, I’ve been using the original Artiphon lightning cable without any adapters.

My original issue with connecting the I1 to the Editor to a 2018 MacBook Pro appears to have been the use of a USB-C adapter.

When I connect the I1 to a Mid-2014 MacBook Pro directly via the original Artiphon USB-A cable, the Editor recognizes the I1 and offers a firmware update.

MacBook Pro running OS X 10.14.6

I installed the Artiphon INSTRUMENT 1 Editor on a Mid-2014 MBP. When I run the Editor app and connect my I1 to that MBP, the app suggests I install a firmware update and never finishes installing the update. The update starts and the progress bar stops near 100%. I don’t get an error. The update process just never clearly finishes. And if I shut everything down and then try again the process repeats.


#4

Hmm, no obvious reason why that shouldn’t work; it sounds like you’re doing all the right things, so is probably one for support@artiphon.com. It looks as if restoring firmware off the Help menu and then updating may do the trick, but I haven’t tried it myself.


#5

Gotcha. I tried Help > Restore which resulted in the same firmware update and the same behavior.

Thanks for trying to help.

I’ve emailed support. We’ll see what they say.


#6

Yes, sorry to have hit a brick wall with this one – I’m really baffled and would love to know what’s going on! But Artiphon will get you sorted, assuming they’re not all going nuts trying to get their new controller out the door during a pandemic…


#7

It’s been a week and I never received a reply from the support ticket I opened at:
https://artiphon.freshdesk.com/support/home

or from the email I sent to support@artiphon.com

I thought perhaps I’d receive an automated response or something but I didn’t get any response. Is that typical?

Are there any other ways or better ways to get ahold of Artiphon support?

Thanks!


#8

I’ve never actually used it myself, so I don’t know what form of acknowledgment is normal – but it’s a ticketed system, so I’d have expected an initial auto-confirmation that you’re in the queue. They may just be shorthanded at the moment with the Orba going into production right on the peak of CoViD; I see they haven’t posted on Twitter since the 13th (though there was a Kickstarter response a couple of days ago, so at least some of the team are coming up intermittently for air). It probably wouldn’t do any harm to resend; the I1 is still usable on your firmware version, but it’s quite elderly and there’ve been some really significant improvements and new features since.